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1.0 Introduction to Arcview 3.2 interface 
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2.0 Creating project 
 
2.1  To create new project or open project  

1. Double click  to open ArcView. A welcome window will appear 
2. To create new project,  choose “with a new view” or “as a blank project”  

OR 
“Open an existing project” 

3. Click OK 
 

 
 
 
2.2 To save and close project 

To save project, choose “Save project as” from the File menu or click the Save Project button  
 
To close project, choose “Close All” and “Exit” from the File menu 
 
 
3.0  Creating a view 
 
3.1  To create new view 

To create a new view, double click the View icon   in the Project Window 
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3.2 Adding theme(s) to a view 
 
3.2.1 To add ArcView shapefile(s) to a view 
 

 

1.  

5. 

4.  
3. 

2. 

 

1. Click on the Add Theme button  
2. Select the drive in the Drives drop down menu 
3. Double click on Directory/Folder to open  
4. Click on the theme (.shp) that you want to add to the project. To select more than 1 theme, hold 

down <SHIFT> and select the themes 
5. Click OK 
6. Check the box next to the theme’s name to turn on the theme 
 

 

Check the box to 
turn on the 
theme. 

   
3.2.2  To plot data with XY coordinates from ArcView 
 
To plot latitude and longitude in ArcView, the latitude and longitude data must be in Decimal Degree 
(DD). If your data is in Degree minute second, DMS (eg. 100°30’49’’), you must first convert them 
into DD before you can plot them in ArcView.  
 
 
Convert DMS to DD by using Degree converter extension 
 
Example: Convert 3.07 N, 113.16 E in Degree minute unit (DM) into DD 
 

1. From menu File, choose Extension 
2. Check the check box next to Degree Conversion 
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3. Click OK to load the Degree Conversion extension  
4. Choose Degree Conversion from the Utilities menu 
5. Enter the latitude to the Deg: and Min:  
6. Click  as shown in the figures below 

 

                            

3.  

2.  

4.  

1.  

 

                  

5.  

6.  

 
 
To plot data with XY coordinates from Arcview 
 
i.) You will have to add the table to the project first before you can plot them in the view. To do so 
please follow these steps: 
 

1. Open Project Window  
2. Choose Add Table from the Project Window 
3. Choose Drives and Directories that contain the Dbase file you want  
4. Choose the file type 
5. Click the name of the shape file that you want to add then click OK (or double click on the file 

name) 
 

ii) Now, you are ready to plot the data in the view. To do so, follow these steps: 
 
1. Click on the View in Project Window  
2. Choose the view that you want to add the data to and double click to open the view 
3. Choose Add Event Theme from the View menu  
4. Select the table that you want to add in from the Table drop down list 
5. Choose the appropriate field from the X field drop list (example: longdec or X_coord)  
6. Choose the appropriate field from the Y field drop list (example: latdec or Y_coord)  
7. Click OK 
8. Turn on the new theme by checking the box. Each unique location in the table will be 

represented by a point as shown in the figure below 
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3.2.3  To plot map data with XY coordinates from Brahms 
 
When you have dataset with Latitude and longitude in DM and not in DD format, you can use Brahms 
to convert the LAT LONG fields from DM to DD format by using the Create map option. ArcView 
then will use this created map file to plot the data in View.  
 
i) Log in Brahms 

1.  Double click   to open BRAHMS 
2.  Enter user name and password in BRAHMS main menu to login 

 
 
 
 
 
 
 
 
 
 
 
 

 
 
ii) Activate the Maps module in BRAHMS 
 

3

2 
 

1  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 7
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iii) Add data to RDE File Manager  Add data to RDE File Manager 
  
  

  
  
  
  
  
  
  
  
  
  

  
  
  
  
  
  
  
  
  
  
  
  
  
  
  
  

4.

iv. Create map file from Brahms iv. Create map file from Brahms 

1. Click   1. Click    and BRAHMS mapping window will appear as below 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

2. 

1. 

1. Click Botanical Records and choose 
‘Add/edit botanical records using Rapid 
Data Entry files’. 

2. Click     and right click the mouse  

to add the database. 
3.  Double click on the file name to open the 

file. 

4. In code page message, press cancel and  

the database will appear. 

3. 

2.

1. Check the ArcView check 
box 

2. Check Remove memo fields 
from map file check box 

3. Click Map all. Brahms will 
create a map file with LAT 
and LONG fields  converted 
to DD format as shown in 
the figure below 

3.



                    

Lat Long fields in Degree minute format (DM)           Lat Long fields in Decimal Degree format (DD) 
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3.3 Turning theme on and off 
 

 
 

Check the box to 
turn on the 
theme. Uncheck 
the box to turn it 
off 

 
3.4 Cutting, copying and pasting theme 
 

 

3.4.1  To delete theme(s) from a view 
 

1. Click on the theme(s) that you want to delete in the 
View’s Table of contents to make the theme active 

2. Choose Delete Themes from the Edit menu 
 
3.4.2  To cut or copy and paste theme(s)  
 

1. Click on the theme(s) in the View’s Table of contents 
to make the theme active 

2. Choose Copy/Cut Theme from the Edit menu 
3. Choose Paste Theme from the Edit Menu to paste it or 

you can press <Cltr> V to paste 
 
To select more than one theme, hold down the SHIFT key 
and select the themes that you want to cut/delete/copy. 

 
 
3.5 To change a theme’s name 
 

 

1. Click on the theme in the View’s 
Table of contents to make the theme 
active 

2. Choose Properties from Theme menu 
or click on   

3. Type in the new name in the Theme 
Name text box 

4. Click Ok 
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3.6 To change the name of a view  
 

1. Select Properties from the View menu to display the View Properties dialog 
2. Type in new name in the Name textbox 
3. Click OK 

 
3.7 To choose view map projection 
 
 

 

View in Decimal degree (DD) – 
not projected unit 

 
Decimal degree (DD) is a geographic coordinate system which is not projected. If the map do not 
require high level of locational accuracy, and you are not going to perform any queries based on 
location or distance, you do not need to transform your data to a projected coordinate system. 
However, in our training we need to get precise measurement of distance and area, so we have to 
transform the data to a projected coordinate. Projected coordinate system for Malaysia is Rectified 
Skew Orthomorphic (RSO).   To convert the view in non-projected DD into RSO projection, follow 
these steps. 
 

 

1. 
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9.
2. 

8.
3. 
4. 6.

7.
5. 

 
1. Select Properties from the View menu to display the View Properties dialog box 
2. Rename View1 to Malaysia RSO in the Name textbox 
3. Select ‘meters’ from Map Unit drop menu 
4. Select ‘kilometers’ from the Distance Units drop menu 
5. Click on Projection to display the Projection Properties dialog 
6. Select ‘National Grids’ from the Category drop menu 
7. Select ‘Malaysia and Singapore’ from the Type drop menu 
8. Click OK on the Projection Properties dialog and View Properties dialog. Now the view is 

projected in RSO as shown in the figure below. 
 

 
 
 

 

View in RSO –projected unit 
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3.8 Selecting features on a view 
 
3.8.1 Selecting feature with a mouse 

1.  Click on the theme in the View’s Table of Contents that have the feature you wish to select. 
2.  Click the Select Feature   then click on the feature(s) (points/polygon/lines) that you 

wish to select. Or you can drag a selection box over the features. Selected features will be 
highlighted in yellow. 

 
3.8.2 Selecting features by selecting records in a theme’s table 

1. Click on the theme in View’s Table of Contents that have the feature(s) you wish to select 

2. Click the Open Theme Table button  

3. Click on the Select button  . Click on the record(s) that you wish to select. To select 
more than one record, hold down SHIFT and select the records. Selected records will be 
highlighted in the Table and View as shown in the figure 

 

 
3.8.3 Selecting features using a Query Builder 

 
Selecting feature using one criterion   
 
1. Click on the theme in the View’s Table of Contents that contain the feature you wish to 

select 

2. Click on the Query Builder button  
 

Example: Select Areca latiloba specimens from the family of Palmae dataset 
 

3. Double click on [Species] from the Field list 

4. Click  and double click on "Areca latiloba" 
5. Click New Set 
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Refine query to the selected set   
 
You can refine your query to the set selected.  For example, you want to refine your selection 
to Areca latiloba specimens from Pahang from the set of Areca latiloba that you have selected 
earlier. 

 
1. Double click [Majorarea] from the Fields list 

2. Click  and double click on "Pahang" 
3. Click Select From Set. Now, you will have only specimen from Pahang highlighted in the 

View and Table 
 
 Add query to the selected set   
 
You can also add query to the selected set. For example, you can add collection from Selangor 
to the selected set Pahang Areca latiloba.  

 
1. Double click [Majorarea] from the Fields list 

2. Click  and double click on "Selangor". 
3. Click Add To Set. So, Now you will have all the specimens of Areca latiloba from Pahang 

and Selangor highlighted in the View and Table 
 
 
3.9 Clear selected features on a view 

Click Clear Selected Features button    to deselect all selected feature in active theme 
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4.0 Choosing color and symbols 
 
4.1 Change theme’s colour or symbol 
  

                
 

1. Double click on the Theme in the Table of Contents to open the Legend editor dialog 
2. Double click the symbol to open Symbol Window 

3. Click on Color Palette button   to select colour or Marker Palette  to select symbol 
4. Click Apply 
 

 
4.2 Classify data 
 

1. Double click on the theme in the View’s Table of contents to open legend editor. Select 
Unique value from the pull down list to display features based on defined attribute 

2. Select Value Field from the drop down list. Example: Species 
3. To edit specific symbol, double click on the symbol to display the palette window 

4. To change the colour randomly, click on the  button 

5. To change pattern randomly, click on the  button 
6. To flip the order of the colour, click on  button 
7. Click Apply  
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1.

2.

3. Double click 
to open Symbol 
Window  

4.
5.

6.
7.

 
 
 
5.0 Labeling 
 
5.1 Setting text font, size, style and colour 
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5.1.1 To set text font, size, style and colour before you create the label 
 
1. Select Show Symbol Window from the Window menu 

2. Click Text Palette  to select font type, size and style; and  to select colour 
 
 
5.1.2 To set text font, size, style and colour after the label(s) is created 
 

1. Use pointer tool   to select label(s) that you wish to change the setting 
2. Select Show Symbol Window from the Window menu 

3. Click Text Palette  to select font type, size and style; and  to select colour 
 
 
5.2 Auto-labeling 
 

                   

1. 

2. 

3.

4.

 
1. You can set the position of the text label before you create the labels. Choose Theme 

Properties from Theme menu to display the Theme properties dialog 
2. Click the Text Labels 
3. Choose the position of the label that you want 
4. Click OK 
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5. 
6. 

7. 

8. 

 
5. Choose Auto-label from Theme Menu 
6. Choose the field that you want to label from the Label field list, so the label will be arranged      
accordingly to what you have set in the Theme’s properties earlier  
7. Choose Use Theme’s Text Label Placement Property 
8. Click OK 
 
5.3  Deleting labels and shapes 
 
5.3.1 To delete label and shape using pointer tool 
1. Use pointer tool   to select label(s) that you wish to delete 
2. Select Delete Graphics from Edit Menu or press <Delete> on the keyboard 
 
 
5.3.1 To delete all label and shapes 
  
1. Choose Select All Graphic from the Edit menu 
2. Select Delete Graphics from Edit Menu or press <Delete> on the keyboard 
 
5.3.2 To delete label associated with active theme (which is created using Auto-label) 
 
Choose Remove Labels from Theme menu  
 
 
6.0 Creating and editing theme 
 
6.1 Creating new theme in a view 
 
There are 3 types of GIS data; point, line and polygon. Each data type represents the real world data. 
For example, we use point data type to represent trees locations, line to represent pipe line and 
polygon to represent parcel.  
 

 18



 
 
Let’s try to create a convex hull polygon of a palm species by following these steps: 

1. Choose New Theme from the View menu 
2. Choose Feature Type that you wish to create 
3. Specify the folder where you want to save the new theme 
4. Rename the default file  
5. Click OK 

6. Click on the Drawing Tool Palette and choose  Irregular polygon button  
7. Left click on the point where you want to start then click once on every point that forming the 

boundary of the polygon. 
8. Double click on the final point to end 
 

                                                                                     

Drawing Tool 
Palette 

Point
Straight line 

Dashed line around 
the check box shows 
that the theme is in 
editing mode 

Line
Rectangular polygon 
Circular polygon 
Irregular polygon 
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6.2 Editing polygon theme 
 

Make sure the theme you want to edit is in 
Editing mode, if not choose Start editing 
from Theme menu. 
 
6.2.1  To reshape the polygon 
1. Click on the  Vertex Edit Tool   
2. Place the cursor on the hollow square 
vertex that you want to move, hold down 
the left mouse button and drag the vertex to 
new position. 
 
6.2.1  To add new vertex 
1. Click on the  Vertex Edit Tool   
2. Move the cursor to the position on the 
line where you want to add the new vertex. 
  
After finish editing, choose Stop Editing 
from Theme menu, and click YES to save 
edits. 

Hollow square 
vertex  

 
7.0 Laying out maps 
 
7.1 Creating and setup new layout  
 
7.1.1 Layout Properties 

1. Double click on the Layout icon in the Project Window  . A new layout will appear 
Choose Properties from the Layout menu 

2. Rename Layout  
3. Uncheck the Snap to Grid check box 
4. Click OK 

 
7.1.2 Page setup for new layout 
 

1. Choose Page Setup from the Layout Menu 
2. Set Page size and orientation 
3. Set Output Resolution to High 
4. Click OK 
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7.2 Adding a view to a layout 
 

 
 
 
1. Click on the View Frame tool   
2. Draw a box on the layout to add a view frame and it 

will display the View Frame Properties Dialog  
3. Select View that contain the features 
4. Check the Live Link check box  
5. Choose scale 
6. Click OK 

 

 
7.3 Adding a legend to a layout 
 

1. Click on Legend View tool    
2. Draw a box on the layout to add a Legend view frame, a Legend Frame Properties dialog will 

appear  
3. Select the View that the Legend is associated with 
4. Click OK 

 
 
 
7.4 Adding a title to layout 

1. Click on the Text tool  
2. Bring the cursor to where you want to put the text 
3. Type text in the text box and click OK 
 
 

7.5 Adding scale bar to a layout 
1. Click on the Scale Bar View tool   
2. Bring the cursor to position where you want to put the scale bar and drag a box of the 

size/length that you want the scale bar to be, Scale Bar Properties Dialog will appear 
3. Select the View Frame associated with the scale bar 
4. Select the style, set the units, interval, intervals and left divisions 
5. Click OK. You can resize the scale bar by dragging the corner using mouse 
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Examples: 

 
Interval: 100  
Intervals: 2 
Left Divisions: 2 

 Left Division Interval 

 
Interval: 50 
Intervals: 6 
Left Divisions: 2 

 
 

Interval: 100 
Intervals: 2  
Left Divisions: 0 

7.6 Adding a north arrow to a layout 
1. Click on the North Arrow tool   
2. Bring the cursor to position where you want to put the north arrow and drag a box of a 

size/length that you want the scale bar to be, a North Arrow Manager Dialog will appear 
3. Choose the design/type Arrow that you want 
4. Click OK. You can resize the scale bar by dragging the corner using mouse 

 
7.7  Adding Graticule and measure grid 
 

1. Load the Graticule and measure grid extension to the project 
2. Choose Add Graticule or Grid from the Layout menu 
3. Select the view frame that you want to add the Graticule on from the drop list 
4. Uncheck the Create a measured grid if you want to create Graticule only. 
5. Click Next 
6. Choose Labels only from the Graticule option 
7. Choose/set the latitude and longitude interval 
8. Choose the Graticule colour, Label text font type, size and style 
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9. Click Next 
10. Check the Align labels to border check box 
11. Choose the line colour and style 
12. Click preview to display the Graticule on the map 
13. Click finish 

 

         

1. 

2.
 

 

3.

4.

5.
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6. 

 
 
 
 
 
 
 

 

11. 

10.

8. 

7.

9.

12.
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13.

 
 

 
 
 
7.8 Export layout 
 
Layout can be saved in jpeg, bitmap format etc. To do so, please follow these steps: 
 

1. Choose Export from the File Menu. An Export dialog will appear. 
2. Choose the Drives and Directory where you want to save the layout 
3. Select the file type 
4. Type in file name  
5. Click on Options 
6. Set JPEG option to maximum for Resolution (DPI):  144 and Quality:100  
7. Click OK in JPEG options and Export dialog 
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4. 

5. 

2.
7.

6. 
3. 

 
 
7.9 Duplicating layout using Memo Tools extension (Hill, B. 2008.  Memo Tools 6.5. Available 
at http://arcscripts.esri.com) 
 
7. 9.1 To install the Memo Tools Extension. 
 

1. Copy the Memo_Tools.avx into the C:\ESRI\AV_GIS30\ARCVIEW\EXT32 
2. In the project, choose Extensions from the File Menu  
3. Check the Memo Tools 6.5 check box 
4. Click Ok. Menus from Menu Tools 6.5 will be added to View, Table and Layout menu bar as 

shown in the figures below 
 
 
 
Memo Tools in active View Memo Tools
 

 
 
Memo Tools in active Layout 
 
 

 

Memo Tools
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7.9.2 To duplicate Layout 
 
1. Open the layout that you wish to duplicate/copy  
2. Choose Duplicate Layout from Memo Tools menu 
3. Enter name for the copy of the layout 
4. Click OK 

 

 
 
 
8.0 Working with tabular data 
 
8.1 Adding table (.dbf ) to a project 
 

1. Open Project Window and click on tables 
2. Choose Add Table from the Project Window 
3. Choose Drives and Directories that contain the Dbase file that you want  
4. Choose the file type 
5. Choose the file name that you want to add and click OK (or  Double click on the file name) 
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8.2 Querying a table 
 
8.2.1 Finding a record in a table 

1. Click the Find button    
2. Type in attribute that you want to find (eg. Fraser’s Hill) 
3. Click OK. The records contain the word Fraser’s Hill will be highlighted in the Table as shown 

in the figure below 
 

 
 
8.2.2 Selecting record(s) in a table  
There are few ways that we can use to select record(s) in a table: 

1. Using  Select tool  to select record in a table. To select more than one records, hold  
<SHIFT> and drag/click on the records  

2. Using Find   to select particular records (Please refer to 8.2.1) 

3. Using Query Builder   (Please refer to 3.8.3) 
4. Selecting records in a Table by selecting feature in the View (Please refer to 3.8.1) 

 
8.2.3 To display selected record(s) on top of the table 

Click Promote button  to display selected record(s) on the top of table. 
 
8.2.4 Getting statistic about a table 
For example, you want to know the total area of a polygon. To do so, please follow these steps: 
 

1. Click on the polygon theme (eg. polygon_calamus_tumidus) to activate it 

2. Click on  to open the theme’s attribute table 
3. Click on the field SqKilometers (since we want to know the total area in km2) 
4. Choose Statistic from Field menu to generate the report. The value next to the word Sum is the 

total area 
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Total area of 
the polygon 

8.3 Editing table 
 
8.3.1 Adding and deleting field in a table  
 

1. Select Start Editing from the Table menu to make the table editable 
2. Choose Add Field from the Edit menu 
3. Enter the name of the field 
4. Choose the type of the field 
5. Set the width of the field 
6. Set the decimal places, if the field is for number 
7. Click OK 
8. Select Stop Editing from the Table menu  
9. Click Yes  to save edits 
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1. 

2.

                   

4. 

5. 

3. 7.

8.

6. 

   

 
9. 

 
8.3.2 Deleting field in a table 
 

1. Select Start Editing from the Table menu to make the table editable 
2. Click on the field name that you want to delete 
3. Choose Delete Field from the Edit menu 
4. Select Stop Editing from the Table menu  
5. Click Yes  to save edits 

 
8.3.3 Adding and deleting record in a table  
 
Before start adding/deleting records, Select Start Editing from the Table menu to make the table 
editable 
 
1. To add new record(s). Choose Add Record from the Edit Menu  
2. To delete record, select the record that you want to delete. Then choose Delete Record from the Edit 
menu 
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8.3.4 Editing values in a table 

1. Choose Start Editing from Table menu 

2. Click on Edit tool  and bring the cursor to the field that you want to edit 
3. Type in new value 
4. To confirm and save the changes, choose Stop Editing from Table menu and save edits 

 
 
9. 0 Extensions 
 
Extensions are tools that provide additional function to ArcView. 
 
9.1 Installing new extension 
 
To install new extension to ArcView, copy the extension file (.avx) into 
C:\ESRI\AV_GIS30\ARCVIEW\EXT32 
 

 

9.2 To add extension to a 
project 
 

1. Open project  
2. Choose Extension from the 

File menu 
3. Select extension(s) that you 

want to add/load to the 
project. 

4. Click OK. You will see new 
menu(s) from the extension on 
the Menu Bar 

 

 
 
 
 
 
 
 
 
 
 
 
 
 

 31



Tutorial: Preparing dataset and creating species distribution, EOO and AOO map 
for Malaysia Plant Red List Assessment by using Arcview 3.2 
 
This tutorial will guide you on how to prepare the dataset and to create species distribution, EOO and 
AOO map for Malaysia Plant Red List Assessment. In this tutorial, you will: 
 

1. Create new project from the project template  
2. Fill in latitude and longitude to the gazetteer field 
3. Classify data (Herbarium specimen, Voucher specimen, Literature and Ex situ collection) 
4. Add base map of Sabah and Sarawak to project and change the colour to be used in the display 
5. Plot species distribution and convert it into shape file 
6. Change the symbol/colour and size of the points 
7. Create a convex hull polygon  
8. Clip polygon (if the polygon is crossing the sea or country boundary) 
9. Label the points  
10. Create map and map design 
11. Calculate the area of the convex hull polygon and add the result to the excel data sheet and 

map  
12. Calculate the forest cover within its convex hull polygon and add the result to the excel data 

sheet and map  
13. Calculate AOO using CATS extension and add the result to the excel data sheet and map 

layout 
 
 
1. Create new project from the project template 

1. Double click  to open ArcView 
2. Choose Open an existing project in the ‘Welcome to ArcView GIS’ window  
3. Click OK 
4. Navigate to folder ‘EOO and AOO workshop 2009’ 
5. Double click at Malaysian_Redlist_template.apr to open the project 
6. Choose Save Project As from File menu 
7. Select the folder ‘EOO and AOO workshop 2009’ 
8. Name the new project as ‘Training EOO’ 
9. Click OK 
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There are 3 views in the project template. The description of each view is as shown in the table below:  
 
 View Projection  Description  
a.  Plot Distribution Decimal degree (DD) To plot species distribution and to create convex 

hull polygon 
b. Calculate  RSO To calculate area of convex hull polygon (EOO) 

and forest cover within its convex hull polygon 
c. Redlist Assessment Decimal degree (DD) To calculate AOO using CAT extension  
 
2. Add base map of Sabah and Sarawak to project and change the colour to be used in the 
display 
 

1. Add theme called ‘Sabah_sarawak boundary’ to Plot Distribution, Calculate and Redlist 
Assessment views. 

2. Add theme on forest cover to the Calculate view (if any) 

3. Click on Save button  to save project 
 
Then, change the colour of the ‘Sabah_sarawak boundary’ theme from solid to “no fill”. To do so, 
  

1. Double click on Sabah_sarawak boundary.shp to open the Legend Editor dialog 
2. Double click on the symbol to open the Symbol Window  

3. Click on the Fill palette button   
4. Select the “no fill” option 
5. Click Apply on the Legend Editor dialog. You will get a view look like the figure below 
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3. Fill in latitude and longitude to the gazetteer field 
 
Add Licuala valida.dbf to the project, to do so: 
 

1. Click on Table in Project Window 
2. Click Add  
3. Navigate to the Folder ‘EOO and AOO workshop 2009’ 
4. Select Licuala valida.dbf and Click OK. Double click the Licuala valida from the Layout 

window to open the table 
 
Now, you are ready to plot the records in the view. To do so, please follow these steps: 
 

1. Choose Add Event Theme from the View menu  
2. Select table that you want to add in from the Table drop list 
3. Choose Longdec for X field  
4. Choose Latdec for Y field  
5. Click OK 
6. Turn on the new theme by checking the box. Each location in table will be represented by a 

point. For record(s) without coordinate, it will appear as outlier as circled in the figure below. 
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Outliers 
(Records without 
coordinates) 

 
Now, try fill in the latitude and longitude to the Table as below: 
 

Gazetteer Latitude (deg.min) Longitude (deg.min) 
Pusso stream 3.07 113.16 
Ulu Membakut 5.23 115.48 

 
7. Make the table editable  
8. Enter the latitude and longitude to the Pusso Stream (Please refer to 8.3.4) 
9. Convert latitude to DD unit. To do so, Load the Degree Conversion extension then select 

Degree Conversion from the Utilities menu.  Enter the latitude to the Deg: and Min: then 
click . Copy the result to the latdec field in the table 

10. Repeat step 2-3 for Ulu Membakut 
 

                   
 
Note: If you have large dataset with lat & long in DM and not DD, you can plot the data in Arcview 
from Brahms (Please refer to 3.2.3) 
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4.   Classify data (Herbarium specimen, Voucher specimen, Literature and Ex situ collection) 
 
You have to classify your data into the 4 categories mentioned above. Please refer to 8.3.1 and 8.3.4 
on how to edit table. 
 
5.  Plot species distribution  
 
Add your table the project and plot the data in the view Please refer to 3.2.2 and 3.2.3 on how to plot 
data in ArcView 
 
6. Convert the theme into shape file  
 
Now, you have to convert the Licuala_valida.dbf into shape file. This is because to create polygon and 
to calculate AOO using CATS, the theme has to be in shape file. To convert theme to shape file: 
 

1. Click on the Licuala_valida.dbf theme to make it active 
2. Choose Convert to Shapefile from the Theme menu. (If there is any outlier, you have to select 

valid record by using Select tool  before you make the conversion, as shown in the figure. 
3. Choose directory where to save the theme shape file 
4. Name the shape file as Plot_licuala_valida 
5. Click OK 
6. Turn on the Plot_licuala_valida.shp theme 

7. Click on the Zoom to Full Extent button  to view all feature in the view 
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Select only the 
valid records 
before convert 
them into shape 
file 

 
 
7. Change the symbol/colour and size of the points 
 

1. Double click on Plot_licuala_valida.shp to open the Legend Editor dialog 
2. Double click on the symbol to open the Symbol Window  

3. Click on the Symbol palette button  and change the size to 20 

4. Then, click on the Colour pallete    and select black colour  
5. Click Apply on the Legend Editor dialog 
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8. Creating a convex hull polygon  
 
Convex hull or minimum convex polygon is used to measure Extent of occurrence (EOO). This 
polygon is drawn by connecting all the outer most point, with no internal angle exceeding 180°. A 
convex hull polygon can be only drawn when the species have more than 2 unique localities.  
 
Now, try to create convex hull polygon for Licuala valida by using CA Tool extension (Hill, B. 2002. 
CA Tools Version 2.E . Available at http://arcscripts.esri.com) 
 

1. Load CA Tools (Crime Analysis Tools-Vers.2.E) 
 File      Extension       check the Crime Analysis Tools-Vers.2.E check box      Click OK 
2. Click on Plot_licuala_valida.shp in Table of Content to activate the theme 

3. Click CA Tools button  to display the menus 
4. Click on the Create a convex Hull Polygon of the crime series point button  
5. Choose CONVERT TO A SHAPE FILE to create polygon in shape file 
6. Click OK 
7. You can ignore the ENTER DIRECTORY PATH dialog by clicking OK or you can enter 

the directory path, where you want to save the shape file and then click OK 
8. Specify the directories where you want to save the shape file 
9. Rename the shape file  
10. Click OK. The polygon theme will be added to the Table of Contents 
11. Click DONE to exit the CA Tools Menu 
 

              

1. 

2.

 
 

 

3.
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4. 

6.

5.

   
 

 

7.

 
 

                  

10.
9. 

8.
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Clipped the polygon with Sabah and 
Sarawak boundary (to exclude sea 
and Kalimantan) to get the accurate 
extent of occurrence of the species in 
Sabah and Sarawak  

 
 
9. Clip polygon using  Geoprocessing extension (if the polygon is crossing the sea and/or 
country boundary) 
 

1. Load the Geoprocessing extension to the project 
2. Select Geoprocessing Wizard to display the Geoprocessing window from the View menu 
3. Select input theme to clip: Licuala_valida-cvhull.shp 
4. Select a polygon overlay theme: Sabah_sarawak boundary.shp 
5. Specify the output file and name the new theme as clip_Licuala_valida-cvhull.shp 
6. Click Finish 
7. Turn on the clip_Licuala_valida-cvhull.shp theme  
8. Change its solid foreground to “no fill” 
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1. 

2.
 
 
 
 

                       

3. 

4. 

5. 

6.
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Clipped polygon after geoprocessing   

 
10. Label the points 
 

1. Open the Plot_licuala_valida attribute table  
2. Choose Start Editing from the Table menu 
3. Choose Add new field from the Edit menu 
4. Name the field as “Point no” 
5. Click OK. The field “Point no” will be added to the attribute table 
 
Now, we can start labeling. 
 
6. Activate the table. Select the first point from the view using the Select Feature tool . The 

selected record will be highlighted in the attribute table 

7. Click on the   in the attribute table and type 1 to the highlighted record on the ‘Point_no’ 
column 

8. Repeat step 6-7 to label the remaining points. Label 10 points at most that form the EOO 
polygon boundary 

9. When you finish, choose Stop Editing from the Table menu and click YES to save edits 
10. Click on the Point_no field to activate it 

11. Click the Ascending button  to sort all the record ascending by Point_no 
12. Select the records that you have put in numbers 

13. Click the promote button  to bring all the selected record to the top  
14. Click on the Plot_licuala_valida in the ‘Plot Distribution View’ Table of Contents to activate it 
15. Choose Auto label from the Theme menu 
16. Choose the Point_no from the Label field list 
17. Choose Use Theme’s Text Label Placement Property 
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18. Click OK 

19. Rearrange the position of the numbers in the view by using pointer tools   

20. Click  Clear Selected Features button   to clear selection 
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11. Create map and map design 
 
11. 1  Duplicate Layout template 
 

1. Open the Layout_Template_SS_aug 2009 
2. Load the Memo Tools extension 
3. Choose Duplicate Layout from the Memo Tools menu 
4. Named the duplicate as Licuala valida SS 
5. Click OK 

 
11.2 Link view to the view frame 
 
You have to link Plot Distribution view to the view frame in layout. To do so, follow these steps: 

 
1. Double click in the view frame to display the View Frame Properties 
2. Select Plot Distribution from the View list 
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3. Check the Live Link check box 
4. Set scale to 1: 4000000 
5. Click OK 

 

 

View Frame

 
Notes: All text circled has to be changed accordingly to the species. 
 
 
12. Calculate the area of the convex hull polygon (EOO) 
 
All calculation has to be done in “Calculate” view which is projected in RSO 
 

1. Copy clip_Licuala_valida-cvhull.shp to the Calculate View 
2. Click on clip_Licuala_valida-cvhull.shp to make the theme active 

3. Click the CA Tools button  
4. Click  button (Calculate area, and perimeter in current map units for polygon or line 

themes)  
5. Click OK in the pop up window/dialog 

6. Click  button to open its attribute table 
7. Click on the SqKilometers field  
8. Choose Statistic from the Field menu to generate report 
9. The value after Sum is the total area of the polygon and also is the EOO of Licuala valida. 

Copy this value to the column EOO in the Excel data sheet and map.  
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Copy to  

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 46



 
13. Calculating forest cover within its convex hull polygon (EOO) 
 
Calculation has to be done in “Calculate” view which is projected in RSO 
 

                 
 
You have to clip the polygon with the forest cover theme to get the forest cover (forested area) within 
the polygon. 
 

1. Add the forest cover shape file to Calculate View 
2. Load the Geoprocessing extension to the project 
3. Select input theme to clip: Forest cover shape file  
4. Select a polygon overlay theme: clip_Licuala_valida-cvhull.shp 
5. Specify the output file and name the new theme as hutan_Licuala_valida-cvhull.shp 
6. Click Finish 

 
Now, you have to calculate the area of the forested area within the polygon 
 

7. Turn on the hutan_Licuala_valida-cvhull.shp theme  

8. Click the CA Tools button  
9. Click  button (Calculate area, and perimeter in current map units for polygon or line 

themes)  
10. Click OK  

11. Click  button to open its attribute table 
12. Click on the SqKilometers field (as we want the area in km2 ) 
13. Choose Statistic from the Field menu 
14. The Sum value is the total forest area in the polygon. Copy this value to the column Forest 

cover in the Excel data sheet. Percentage of forest cover within the polygon will be calculated 
in Excel data sheet. Copy the result in percentage to the map 
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14. Calculating Area of Occupancy of a species (AOO) using CAT extension (Moat, J. 2007. 
Conservation Assessment Tools extension for ArcView 3.2, version 1.2. GIS unit, Royal Botanic 
Gardens Kew. Available at http://www.rbgkew.org.uk/gis/cats) 
 

1. Copy the Plot_licuala_valida.shp to the “Redlist Assessment” view 
2. Click on Plot_licuala_valida.shp in the Table of contents to make it active  
3. From the Red List Tools, choose Preliminary IUCN assessment – Single 
4. Enter the width of the grid cell that you want to use  
5. Click OK 
6. A report window will appear. Copy the AOO area into the excel datasheet 

 

      
 
 

 
 
    
Notes: In CATS, you can also run the preliminary Red List assessment in batch. Please refer to the 
“Documentation for using CATS in ArcView” at http://www.rbgkew.org.uk/gis/cats on how to run 
CATS in batch. 
 
 
 
 
 
 
 
 

 48


	Manual on how to prepare EOO and AOO maps using ArcView GIS
	Table of contents
	Introduction to Arcview 3.2 interface
	Creating project
	Creating a view
	Choosing color and symbols
	Labeling
	Creating and editing theme
	Laying out maps
	Working with tabular data
	Extensions
	Tutorial: Preparing dataset and creating species distribution, EOO and AOO map for Malaysia Plant Red List Assessment by using Arcview 3.2 



